Installer une autre version de noyau

Topic Resolution: Resolved

Étiqueté : 

  • Créateur
    Sujet
  • #15975
    lotfi
    Maître des clés
    • 35

    Le noyau Linux est en constante évolution. Chaque nouvelle version d’Ubuntu inclut une nouvelle version du noyau Linux par rapport à la précédente. Si cela permet de corriger des bugs et de proposer de nouvelles fonctionnalités, il arrive que cela entraîne des régressions (dans le pire des cas, cela empêche de démarrer Ubuntu). Dans ce cas, vous pouvez être amené à installer d’autres versions du noyau Linux (plus récentes ou plus anciennes).

    Si dans une version LTS d’Ubuntu vous souhaitez utiliser de manière sécurisée le noyau d’une version d’Ubuntu stable supérieure, voir cette page.

    Installer et utiliser une autre version de noyau est à réserver aux utilisateurs avertis.Ne pas installer un noyau d’une architecture différente de celui déjà pré-installé.

    L’installation du noyau d’une autre version d’Ubuntu rend impossible l’installation des pilotes supplémentaires, qui seront toujours « activés » mais pas en cours d’utilisation.

    La version du serveur graphique pré-installée n’est pas forcément compatible avec d’autres noyaux. Sauf à savoir ce que vous faites, n’installez pas un nouveau noyau sans installer la version du serveur graphique correspondante.

    Modifier : Installation simple

    Rendez-vous sur le site correspondant à la version de noyau voulue: soit packages.ubuntu.com (kernels stables, par défaut de toutes les versions d’Ubuntu), soit kernel.ubuntu.com (version de développement, appelée « mainline », que les développeurs vous demanderont généralement de tester).

    Téléchargez les 4 paquets composant le kernel voulu, généralement:

    • linux-headers-<version>_<version>_all.deb
    • linux-headers-<version>-generic_<version>_<votre_architecture>.deb
    • linux-image-<version>-generic_<version>_<votre_architecture>.deb
    • linux-image-extra-<version>-generic_<version>_<votre_architecture>.deb (optionnel, mais généralement requis pour les tests)

    Si votre système est 64bit, <votre_architecture> est amd64.
    Si votre système est 32bit, <votre_architecture> est i386.

    Installez les paquets téléchargés (par exemple en double-cliquant dessus puis installer via la Logithèque) dans l’ordre ci-dessus.

    Mettre à jour le menu Grub (sudo update-grub)
    Redémarrez l’ordinateur. Le menu GRUB vous permettra de choisir le nouveau noyau.

    see You soon
    www.milbako.com
    e-mail : Webmaster

  • Vous devez être connecté pour répondre à ce sujet.
Translate »